FCDEV3B bring-up status

Mychaela Falconia mychaela.falconia at gmail.com
Sat Apr 8 08:45:24 UTC 2017

Hello FreeCalypso community,

After running a few more tests I reached the conclusion that the most
likely reason why our FCDEV3B running FC Magnetite fw is currently
unable to connect to a live commercial GSM network is not because of
some physical problem with the RF tract, but simply because of the
lack of calibration for the VCXO.  I have reached this conclusion
based on the following observations:

1. Serg and Harald asked me to try running OsmocomBB on this board.  I
   did as they asked (when running OsmocomBB on the FCDEV3B, use the
   gta0x version of layer1.highram.bin, *not* any of the compal ones -
   the gta0x build works unchanged on the FCDEV3B), and it appears to
   work.  I did not take it as far as running the full mobile app (I
   may try it next), but I ran their cell_log app, and it found the
   local cells of Operator 310260, and reported the TA for each of
   them.  Finding the TA requires sending a RACH and getting an IMM ASS
   back, thus having cell_log work to this extent indicates that the
   RF tract on the FCDEV3B must be good in both Rx and Tx directions!

2. As an experiment, I fully erased the FFS on a GTA02 modem,
   reinitialized it with just /etc/IMEISV and /gsm/com/rfcap (no RF
   calibration files), and tried connecting to the network.  Result:
   it fails in exactly the same way as our FCDEV3B currently does.
   When I restored the afcdac and afcparams files under /gsm/rf and
   rebooted, the modem happily connected to my local cell - thus it is
   the VCXO calibration that's critical here, not any other Rx or Tx
   calibration parameters.

Now here are the two big questions to which I have no answers:

1. The AFC algorithm used by OsmocomBB looks totally different from
   the one used by TI's TCS211 fw, and I am not enough of a guru to
   understand the differences between the two or their relative
   merits.  OsmocomBB's version does not require calibration and has
   no provision for making use of such, whereas TI's version expects
   that each MS gets individually calibrated on the production line.

   Doing per-unit calibration on production lines requires time and
   special equipment, i.e., money.  I figure that the mainstream
   manufacturers would not be doing such per-unit calibration if it
   could be avoided, hence there must be some good reason for doing
   this calibration.  But if so, then how is OsmocomBB able to get
   away with having no calibration provisions at all?

2. When we run our FreeCalypso firmwares on Mot C1xx phones, we don't
   have any calibration values (Compal did not use TI's standard
   format, and we don't know how to grok their proprietary one), yet
   our firmwares running on these targets connect to GSM networks just
   fine.  But the very same sans-calibration configuration with the
   same fw fails on GTA02 and FCDEV3B hardware!

Just to be clear, the purpose of the FCDEV3B is to run TCS211 or
TCS2/TCS3 hybrid firmware in its full glory.  Running OsmocomBB on the
FCDEV3B is certainly possible, but pointless: right this moment there
are 29 listings on ebay for Mot C139 phones, with prices in the $5 to
$20 range, and for OsmocomBB our FCDEV3B offers absolutely no advantage
over these obscenely cheap Mot C1xx phones, hence buying a very
expensive board like ours only to run OsmocomBB would be a waste of
money.  Instead the purpose of our board is run TI's TCS211 fw in its
full glory with CSD, fax and GPRS services, which is not possible on
Mot C1xx phones.

Hence in order to achieve our goal of running the firmware we like, it
looks like we will have to bite the bullet and calibrate our boards on
the CMU200 before we'll able to connect to GSM networks using our
choice of fw.  Climbing the very steep learning curve of the CMU200
and of the calibration procedures is now on my to-do list.

Hasta la Victoria, Siempre,
Mychaela aka The Mother

More information about the Community mailing list